Updated build for libcoap something in tje build process now requires OpenSSL...

Updated build for libcoap something in tje build process now requires OpenSSL libraries which are not that easy to upgrade
14 jobs for update_docker_base_image in 0 seconds